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Monitoring environmental conditions near
underwater datacenters using Deep
Learning
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working to solve global environmental challenc
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Using the New Xamarin.Forms Controls
Toolbox
Xamarin.Forms empowers deliver the same

TypeScript and Babel 7
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View Existing Projects

Perhaps code you’ve downloaded from College Server
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View > Object Browser
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Start a new solution



File > New > Project > Other Project Types

Start a new
solution

Mew Project

indows Classic Desktop

MET Framework 4.6.1

I | Blank Solution

fSharePoint
.MET Core
.MET Standard
Cloud

Platform

ibility

orkflow
isual Basic
isual C++
b Visual F#
S0L Server
Azure Data Lake
I JavaScript
I+ Streamn Analytics
I+ TypeScript
Game
4 Other Project Types

Visual Studio Solutions

Mot finding what you are locking for?

MName: MyProject
Location:

Solution name:

* Sort by: Default

Visual Studic

solutions

Type: Visual Studio Solutions

Create an empty solution containing no
projects

Browse...

|:| Create new Git repository

OK Cancel




Starting and Building Projects

Perhaps to add a project to an existing solution



File > New > Project > C#

New Project ? X

b Recent MET Framewerk 4.6.1 - Sort by: Default

4 [nstalled c# Vel
] WPF App (NET Framework) VisualC¢  ype: Visual &
4 Visual C# i A project for creating a command-line

Windows Universal Windows Forms App (.NET Framework) Visual C# application

Windows Classic Desktop

Console App (.NET Framework) Visual C#
I+ Office/SharePoint
.NE Class Library (.MET Framework) Visual C#
.NET 5tandard

Shared Project Visual C#
Windows Service (MET Framework) Visual C#
Empty Project (.NET Framework) Visual C#

I Visual Basic WPF Browser App ((NET Framework) Visual C#
4 Visua
WPF Custom Control Library ((NET Framework) Visual C#
Windows Universal
General WPF User Control Library (\NET Framewaork) Visual C#
ATL

Tt Windows Forms Control Library (MNET Framewaork) Visual C#

Mot finding what you are looking for?

Mame: Consolefppl
Location: (\MotReleasedYet',

Solution name: Consolefpp1 Create directon solution

|:| Create new Git repository

OK Cancel




CH# Project > Properties > Application

Edit
B -
Toker # X
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Build
Build

Debug

Publish

de Analy

Assembly name:
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Default namespace:

Toker

| ‘Toker

Target framework:

Output type:

MET Framework 4.6.1

Console Application

{NET Framework 2.0

{NET Framework 3.0

{NET Framewaork 3.5

NET Frarnework 3.3 Client Profile
MNET Frarmework 4

.NET Framework 4 Client Profile
{MET Framework 4.5

{NET Framework 4.5.1

{NET Frarework 4.5.2

NET Framewaork 4.6

NET Framework 4.6.1

Install other frameworks...

Unity 3.5 .net full Base Class Libraries
Unity 3.3 .net Subset Base Class Libraries
Unity 3.5 Micro Base Class Libraries
Unity 3.5 Web Base Class Libraries

Assembly Information...

ication. To embed a custom manifest, first add it to

~ | Browse...

|Embed manifest with default settings

v |

(O) Resource file:

You may need to
change Framework
version used for
builds, e.g., an old
solution may require
a Framework version
you don’t have on
your machine.

- 0

Fawcett ~

> 0 x
S¢Gadm@
pv

# Add to Source Control a



CH# Project > Properties > Application

Juick Launch (Ctr - o
Edit  View ] Bi ) m &7 Full Screen J Fawcett -
SR, : =
Toker # X =0 v A
Application . ; P ¢ F@
Build . -

Build Assembly name:

Default namespace:
Debug Toker | ‘Toker

Target framework: Output type:
MET Framework 4.6.1

~ ‘Canso\eApplicatioﬂ

Startup object:
(Mot set) Class Library

Resources
Publish Specify how application resources will be managed:

de Ana (®) Icon and manifest

A manifest determines specific settings for an application. To embed a custem manifest, first add it to
your project and then select it from the list below.

lcon:
|Default Icon)

V| Browse... | |H '

Manifest:

|Embed manifest with default settings

v |

(O) Resource file:

# Add to Source Control a



roject > Properties > Build

Debug  Team T Iy 0 ©  Full Screen

Debug - AnyCPU

Application X . .
Configuration: | Active (Debug) Platform: | Active (Any CPU)
Build

Build 3 General

Debuc
g Conditional compilation symbols: | TEST_TOKER

Define DEBUG constant
SEN
= Define TRACE constant
Settings
Platform target:

Prefer 32-bit

nce Paths

Signing
- . [ Allow unsafe code
Security

X O Optimize code
Yublish

Errors and warnings

Warning level:

Suppress warnings:

Treat warnings as errors

® None
O Al
(O Specific warnings:

Output

Dutput path: bin\Debugh

[] ML documentation file:

Generate serialization assembly: Auto

Results

Errer HRESULT E_FAIL has been returned from a call to a COM component. The tab has been closed.

Advanced...

Define to enable
compilation of TestStub
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4 Addto Source Control «



roject > Properties > Debug

Application
Build
Build Ev

\eference Paths
Signing
Security
Publish

Code Analy

4 Full Screen

Lonfiguration: | Active (Debug) Platform: | Active (Any CPU)

Start action
(®) Start project
() Start external program:
() Start browser with URL:

Start options

Command line arguments:

Working directory:

[ Use remote machine

Debugger engines

[] Enable native code debugging
] Enable SQL Server debugging

Put command
line arguments
here
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File > New > Project > C++

Mew Project ? *

I Recent MET Framework 4.6.1 =~ Sort by: Default

i h Windows ¢ e Application Visual C++ Type: Visual C++
b Visual C# A project for creating a Windows console
sual Basic Windows Desktop Application Visual C++ application
4 Visual C++
Windows Desktop Dynamic-Link Library (DLL) Visual C++
Windows Universal

General Static Library Visual C++
Windows Desktop Wizard Visual C++

Bxtensibility
Windows UAP
I Visual F#
SQL Server
zure [ata Lake
JavaScript
I+ Strearn Analytics
/peScript
lhame

I+ Other Project Types

Mot finding what you are looking for?

Name: ConsoleApplication
Location: otReleasedYeth
Solution name: CensolefApplication] eate directory for selution

Create new Git repository

0] 4 Cancel




C++

Project > Properties > General

DemoSomeReqs Property Pages ? >
Configuration: | Active(Debug) | Platform: |Win32 ~ Configuration Manager...
4 Configuration Properties v General You may need to Change these
Genera T < 10
Debugging Windows SDK Version 10.0.16299.0 to matCh yOUF enVIrOI’]ment and
VC++ Directories Output Directorny S5olutionDir)S(Configuration], . o
BoC/Ces Intermediate Directory $(Configuration]’, com pl Ier version
b Linker Target Mame S(ProjectMame)
s =i Target Extension JEXE
e F]Eﬂeratnr Extensions to Delete on Clean *.cdf;*.cache™.obj;*.obj.enc™.ill; ™ ipdb;*.ichj* rescurces ™ tlb;™ th;* tlh,* trp;*.rsp;*.pg
o T Build Log File $(IntDir)$(MSBuildProjectName).log
b Build Events Platform Toolset Visual Studio 2017 (v141)
[ Custem Build Step .
A Enable Managed Incremental Build Mo
v Project Defaults
Configuration Type Application (.exe)
Uze of MFC Use Standard Windows Libraries
Character Set Use Unicode Character Set
Common Language Runtime Support Mo Common Language Runtime Support
MET Target Framework Version
Whele Program Optimization Mo Whole Pregram Optimization
Windows Store App Support Mo
Target Platform
The current target platform of the project.
< >
Cancel Apply




C++

Project > Properties > Configuration Type

Configuration: | Active(Debug) ~ | Platform: |Win32 - Configuration Manager...
4 Configuration Properties v General
General Target Platform Windows 10
Debugging Windows 50K Version 10.0.16299.0
VC++ Directories Output Directory S(5olutionDir) S (Configuration)’,
boC/Cer Intermediate Directory S(Configuration]’,
b L'”k?r Target Mame S(ProjectMame)
bl =irn Target Extension e
B sTErTE l.Seneratcnr Extensions to Delete on Clean *cdf;".cache ™ obj . obj.enc™ilk"ipdb; ™ iob); ™ resources; ™tk ™t ™ b tmp " orsps " pg
I- Browse Information . . . . .
b Build Event Build Log File S{IntDir) 5(M5BuildProjectMame).log
AT e Platform Toolset Visual Studio 2017 (v141)
I Custorn Build Step .
) Enable Managed Incremental Build Mo
I- Code Analysis
~ Project Defaults
Configuration Type Application (.exe) E
Use of MFC Makefile
Character Set Application (.exe)
Comrmon Language Runtime Support Dynarmic Library (.dIl})
MET Target Framework Version Static library (lib)
Whele Program Optimization Utility
Windows Store App Support <inherit from parent or project defaults=
Configuration Type
Specifies the type of output this configuration generates,
< >

oK Cancel Apply




C++ Project > Properties > Configuration Type

Configuration: | Active(Debug) ~ | Platform: |Win32 w Configuration Manager...
4 Configuration Properties v General
General Target Platform Windows 10
Debugging E]
VC++ Directories Qutput Directory 10.0.10240.0
boC/C+ Intermediate Directory 10.0.10586.0
[ Linker Target Mame 10.0.14393.0
- Manifest Tool Target Extension 10.0.15062.0
bl e ‘_EE”E”"” Extensions to Delete on Clean 10.0.16299.0
[ Bru:.uwse Information Build Log File a.1
b Build E"”E”t? Platform Toolset <inherit from parent or project defaults>
[ Customn Build Step .
poTrinireies Enable Managed Incremental Build Mo
v  Project Defaults
Configuration Type Application (.exe)
Use of MFC Use Standard Windows Libraries
Character Set Use Unicode Character Set
Commen Language Runtime Support Mo Commen Language Runtime Support
MET Target Framewaork Version
Whole Program Optimization Mo Whole Program Optimization
Windows Store App Support Mo
Windows SDK Version
Version of Targeted Platform
< >
OK Cancel Apply




C++ Project > Properties > Debugging

Configuration:

DemoSomeReqs Property Pages

Active(Debug)

e v A A A T A

4 Configuration Properties

General

Debugging

YC++ Directories
C/C++

Linker

Manifest Tool

XML Document Generator
Browse Information
Build Events
Custom Build Step
Code Analysis

~ | Platform: |Win32
Debugger to launch:

Local Windows Debugger

? X

~ Configuration Manager..

Command

%(TargetPath)

Command Arguments |

Working Directory
Attach

Debugger Type
Environment

Merge Environment
S0L Debugging

Amp Default Accelerator

S(PraojectDir)
Mo
Auto

Yes
Mo
WARP software accelerator

Put command line
arguments here

S

Command Arguments

The cornmand line arguments to pass to the application.

Cancel

Apply




C++ Project > Properties > C/C++

TestUtilities Property Pages

Configuration: | Active(Debug)

v v

4 Configuration Properties
General

Debugging

VC++ Directories
C/C++

General
Optimizaticn
Preprocessor

Code Generation
Language
Precompiled Headers
Output Files
Browse Information
Advanced

All Options
Command Line

Linker

Manifest Tool

XML Document Generator
Browse Information

Build Events

Custom Build Step

Code Analysis

| Platform: | Win32

Preprocessor Definitions

Undefine Preprocessor Definitions
Undefine All Preprocessor Definitions
Ignore Standard Include Paths
Preprocess to a File

Preprocess Suppress Line Mumbers

Keep Comments

s

w Configuration Manager...

_MBCS; TEST_TESTUTILITIESDEMO; % {Preprocessor Definitions)

This is where you define whether to

compile a package’s TestStub
(see next slide)

Preprocessor Definitions
Defines a preprocessing symbols for your source file,

Cancel

Apply




Option to compile package’s main function

F#include <cc type>
#include <iostream>
#include <memory>»
#include "TestUtilitiesDemo.h"

std::ostream& out = std::cout;

Utilities




C++ Project > Properties > C/C++

DemoSomeReqs Property Pages

Configuration: | Active(Debug)

F|

A A S v A~ A 4

4 Configuration Properties

General
Debugging
YC++ Directories
C/C++
General
Optimization
Preprocessor
Code Generation
Language
Precompiled Headers
Output Files
Browse Information
Advanced
All Qptions
Command Line
Linker
Manifest Tool
XML Document Generator
Browse Information
Build Events
Custom Build Step
Code Analysis

w | Platform: | Win32

Precompiled Header Mot Using Precompiled Headers]

Precompiled Header File stdafi.h
Precompiled Header Qutput File S{IntDir)5(TargetMame).pch

? x

w Configuration Manager...

Precompiled headers

seem to cause more
problems than the
modest improvement in
build times warrant, so |
usually don’t use them.

Precompiled Header
Create/Use Precompiled Header : Enables creation or use of a precompiled header during the build.

(e, )

Cancel Apply




C++ Project > Properties > Linker > Input

DemoSomeReqs Property Pages ? x
Configuration: | Active(Debug) ~ | Platform: |Win32 w Configuration Manager...
4 Configuration Properties Additional Dependencies ole32.lib;oleaut32.lib;uuid.lib;odbe32.lib;odbecp3d.lib; %a{AdditionalDependencies) ~
General Ignore All Default Libraries
Debugging Ignore Specific Default Libraries q
D Module Definition File If your project depends on other
b O+ Add Module to Assembl ; ;
+ Linker oduleto Assembly libraries, add them here.

Ermbed Managed Resource File
General Force Symbol References
Delay Loaded Dlls

Assembly Link Resource

Input
Manifest File
Debugging
System
Optimization
Embedded IDL
Windows Metadata
Advanced
All Opticns
Command Line
Manifest Tool
XML Docurment Generator
Browse Information
Build Events
Custom Build Step
Code Analysis

i

Additional Dependencies
Specifies additional items to add to the link command line, [i.e, kernel32.lib]

Cancel Apply




C++ Project > Properties > Linker > System

Configuration:

Active(Debug)

e A A v

4 Configuration Properties

General
Debugging

YC++ Directories
C/C++

4 Linker

General
Input
Manifest File
Debugging
Systemn
Optimization
Embedded IDL
Windows Metadata
Advanced
All Opticns
Command Line
Manifest Tool
XML Document Generator
Browse Information
Build Events
Custom Build Step
Code Analysis

| Platform: |Win32 e

Console (fSUBSYSTEM:CONSOLE)

SubSystem

Configuration Manager...

[V]

Mot Set
Console (fSUBSYSTEM: CONSOLE)

Minimum Required Version
Heap Reserve Size
Windows (/SUBSYSTEM:WINDOWS)

Mative (/SUBSYSTEM:MNATIVE)

EFl Application [/SUBSYSTEM:EFI_APPLICATION]

Heap Comrmit Size
Stack Reserve Size
Stack Commit Size

Enable Large Addresses
EFl ROM (/SUBSYSTEM:EFI_ROM)

EFl Runtime (/SUBSYSTEM:EFI_RUNTIME_DRIVER)
POSIX (/SUBSYSTEM:POSLX)
<inherit from parent or project defaults=

Terminal Server
Swap Run From CD
Swap Run From Metwork

EFl Boot Service Driver (/SUBSYSTEM:EFI_BOOT_SERVICE_DRIVER)

Drriver
If, when you run in Visual Studio, the program’s
output appears briefly, then disappears, you fix
that by setting SubSystem to Console.
SubSystem

The /SUBSYSTEM coption tells the operating system how to run the .exe file.The choice of subsystern affects the entry peint symbal (or entry point

function) that the linker will choose,

oK

Cancel Apply




Build > Configuration Manager

All the projects in a solution normally target the
same platform.

Configuration Manager ? x
Active solution configuration: Active solution platform:

Debug | xubd w
Project contexts (check the project configurations to build or deploy):

Project Configuration Platform Build Deploy

DemoSomeReqgs Debug ~ || xbd ‘“’

TestUtilities Debug v || x64 v L]

Close




oft Visual Studio

ild |
De

(fstr
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{memo
'File
"../S
‘Demo

Debug Team  Tools  Test

y?

Windows

Graphics

Start Debugging

Start Without Debugging
Attach Unity Debugger
Performance Profiler...
Attach to Process...
Other Debug Targets
Profiler

Run To Cursor

Step Into

Step Ower

Mew Breakpoint

Import DataTips ...

Options...

DemoSomeReqs Properties...

Analyze  Window

F5
Ctrl+F5

Alt+F2

Ctrl+Alt+P

Ctrl+F10

F11
F10

Help
=
aJ
E,
[
B

Degugging Commands

F5: jump to next breakpoint
F10: step next

F11: step into function

AF10 : run to cursor

Set or remove breakpoint by clicking on margin

| added Run to Cursor to the Debug menu, as
shown in the next slide.



Tools > Customize > Commands

Customize ? >

Toolbars | Commands
Toolbars | Commands

Choose a menu or toolbar to rearrange:
Choose a menu or toolbar to rearrange:

(® Menu bar: Menu Bar -
Add Command
) Toolbar: CMake | Cache
s CMake | Cache | Generate Choose the command to add and click QK.
) Context menwu:
CMake | Cache | Delete Cache Folders Categories: TrmTeT
Controls: CMake | Cache | View CMakeCache.d add
ins A
File CMake | Cache | Open Cache Folder Analyze ¢, Refresh Windows app
Add to Refel CMake | Change CMake Settings Build Registers
Build CMake Remote Machine

Edit . .
- Build | Build Debug Restart

View Build | Rebuild Al _ Design
LU, £ jild | Project Only 2 DsL Tools
Project Build | Profile Guided Optirnization Edit
CMake Debug File

Run Current Tile Te Cursor
Run Flagged Threads To Cursor

Run To Cursor

Save Dump As...

Build Debug | Windows Format

N Debug | Windows | Parallel Watch GraphView
Debug | Windows | Watch j | el
Debug | Windows | DOM Explorer '
Team Debug | Windows | Mermary

Q=L AIEbE ] Debug | Graphics i L '
Liloall Debug | Other Debug Targets

Select Element
Start Withoo

Debug

Ok | | Cancel

Keyboard... | | Close

Keyboard... | | Close




The End



